[Resolved] Fatal error when trying to activate moodle plugin

Home Forums Moodle Fatal error when trying to activate moodle plugin

This topic contains 3 replies, has 2 voices, and was last updated by  Joshua Parker 1 year, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #166

    Anonymous

    I get a fatal error when trying to activate the moodle plugin. The error is:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected ‘[‘ in /home/academ38/public_html/test/app/plugins/moodle/moodle.plugin.php on line 31

    Version 6.25 of edutrac sis.

    It also throws a similar error with the helpdesk plugin:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected ‘[‘ in /home/academ38/public_html/test/app/plugins/helpdesk/helpdesk.plugin.php on line 41

     

    #167

    Joshua Parker
    Keymaster

    That is strange that you have eduTrac SIS installed because in order to install it, you have to have at least PHP version 5.4.x installed on your server. If not, you get error messages like the one you posted. So, the errors have to do with not having the right PHP version installed.

    #168

    Anonymous

    PHP version is 5.5.35

    #169

    Joshua Parker
    Keymaster
Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Fatal error when trying to activate moodle plugin’ is closed to new replies.